<!DOCTYPE html><html lang="en"><head><meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/><meta http-equiv="Content-Language" content="en"/><meta name="theme-color" content="#000"/><link rel="shortcut icon" href="https://ph-static.imgix.net//favicon.ico?auto=format&amp;auto=compress"/><link rel="chrome-webstore-item" href="https://chrome.google.com/webstore/detail/likjafohlgffamccflcidmedfongmkee"/><link rel="apple-touch-icon-precomposed" href="https://ph-static.imgix.net/ph-ios-icon.png?auto=format&amp;auto=compress"/><link rel="alternate" type="application/atom+xml" title="Product Hunt - All newest Products" href="https://www.producthunt.com/feed"/><link rel="manifest" href="/manifest.json"/><link rel="search" type="application/opensearchdescription+xml" title="ProductHunt" href="/osd.xml"/><meta charSet="utf-8"/><title>Robo Esso - Automated coffee shop using off-the-shelf hardware | Product Hunt</title><link rel="canonical" href="https://www.producthunt.com/posts/robo-esso"/><meta name="description" content="Robot coffee shop using off-the-shelf equipment to customize their menu faster and offer a larger variety of drinks at a lower price than other robot coffee shops."/><meta name="viewport" content="width=device-width, initial-scale=1, minimum-scale=1"/><meta property="fb:app_id" content="1467820943460899"/><meta property="author" content="Matthew Jones"/><link rel="author" href="https://www.producthunt.com/@roboesso"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@producthunt"/><meta name="twitter:title" content="Robo Esso - Automated coffee shop using off-the-shelf hardware | Product Hunt"/><meta name="twitter:description" content="Robot coffee shop using off-the-shelf equipment to customize their menu faster and offer a larger variety of drinks at a lower price than other robot coffee shops."/><meta name="twitter:image" content="https://ph-files.imgix.net/7c064eb7-f17e-44e5-8e72-2f96dca774c9.jpeg?auto=format&amp;fit=crop&amp;frame=1&amp;h=512&amp;w=1024"/><meta name="twitter:creator" content="@roboesso"/><meta property="og:site_name" content="Product Hunt"/><meta property="og:title" content="Robo Esso - Automated coffee shop using off-the-shelf hardware | Product Hunt"/><meta property="og:type" content="product"/><meta property="og:image" content="https://ph-files.imgix.net/7c064eb7-f17e-44e5-8e72-2f96dca774c9.jpeg?auto=format&amp;fit=crop&amp;frame=1&amp;h=512&amp;w=1024"/><meta property="og:description" content="Robot coffee shop using off-the-shelf equipment to customize their menu faster and offer a larger variety of drinks at a lower price than other robot coffee shops."/><meta property="og:locale" content="en_US"/><meta property="og:url" content="https://www.producthunt.com/posts/robo-esso"/><script type="application/ld+json">[{"@context":"http://schema.org","@type":"SoftwareApplication","image":"https://ph-files.imgix.net/803e3be8-8010-41a9-9e21-2087b8d4cafe.gif?auto=format&auto=compress&codec=mozjpeg&cs=strip","name":"Robo Esso","description":"Robot coffee shop using off-the-shelf equipment to customize their menu faster and offer a larger variety of drinks at a lower price than other robot coffee shops.","url":"https://www.producthunt.com/posts/robo-esso","datePublished":"2021-02-04T08:51:19-08:00","dateModified":"2021-02-04T09:01:35-08:00","screenshot":["https://ph-files.imgix.net/7c064eb7-f17e-44e5-8e72-2f96dca774c9.jpeg?auto=format&auto=compress&codec=mozjpeg&cs=strip","https://ph-files.imgix.net/46e2b280-02f2-4c28-a23a-1a7bb744929f.png?auto=format&auto=compress&codec=mozjpeg&cs=strip","https://ph-files.imgix.net/803e3be8-8010-41a9-9e21-2087b8d4cafe.gif?auto=format&auto=compress&codec=mozjpeg&cs=strip","https://ph-files.imgix.net/c7775718-608f-40ec-9d74-3d355ae848d7.jpeg?auto=format&auto=compress&codec=mozjpeg&cs=strip"],"operatingSystem":["Web"],"applicationCategory":["Robots","Coffee","Tech"],"author":{"@type":"Person","name":"Freeman LaFleur"}},{"@context":"http://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.producthunt.com/"},{"@type":"ListItem","position":2,"name":"Robo Esso","item":"https://www.producthunt.com/posts/robo-esso"}]}]</script><meta name="next-head-count" content="22"/><link rel="preload" href="/_next/static/css/8ddc13539e7056a0a245.css" as="style"/><link rel="stylesheet" href="/_next/static/css/8ddc13539e7056a0a245.css" data-n-g=""/><link rel="preload" href="/_next/static/css/ed07cab7feb53b926cd1.css" as="style"/><link rel="stylesheet" href="/_next/static/css/ed07cab7feb53b926cd1.css" data-n-g=""/><link rel="preload" href="/_next/static/css/58ba985f75de4a7703f0.css" as="style"/><link rel="stylesheet" href="/_next/static/css/58ba985f75de4a7703f0.css" data-n-p=""/><link rel="preload" href="/_next/static/css/afc746272e94ac975c11.css" as="style"/><link rel="stylesheet" href="/_next/static/css/afc746272e94ac975c11.css" data-n-p=""/><noscript data-n-css=""></noscript><link rel="preload" href="/_next/static/chunks/main-fdb656bebd38829c0c01.js" as="script"/><link rel="preload" href="/_next/static/chunks/webpack-a198f19b9e116df221ff.js" as="script"/><link rel="preload" href="/_next/static/chunks/framework-33e18a7bef76c30e15eb.js" as="script"/><link rel="preload" href="/_next/static/chunks/commons-18dad7f673c57e404bcb.js" as="script"/><link rel="preload" href="/_next/static/chunks/69a2a245045fb191ff81ee6aa3481b2a36f5eac3-6d9be4de0bc30217d1d9.js" as="script"/><link rel="preload" href="/_next/static/chunks/995607c2d9eda3fbda8bfd26d8ce135465b8466c-e7dc6fc92bbf5978aa24.js" as="script"/><link rel="preload" href="/_next/static/chunks/87553e297503562a4ae6e9014c11c4cb95affe46-ed9eaeb8839d8469cc98.js" as="script"/><link rel="preload" href="/_next/static/chunks/a38a7eedb7cc15033afc318ff4b5d143d28d1483-956a6d94cdb1d898d8bb.js" as="script"/><link rel="preload" href="/_next/static/chunks/86d29cfda7579c9a258278c079eaf20143224b95-d1000dbc8ed6b6c80d07.js" as="script"/><link rel="preload" href="/_next/static/chunks/fb9b3eab6cb961ac801d4488d9d08b5499fd5367-bc51a7e142a6fe8fa205.js" as="script"/><link rel="preload" href="/_next/static/chunks/b2732580c67f88cf649a6bca17272673f857ee6c-93bcf5d7c5047ffbb68f.js" as="script"/><link rel="preload" href="/_next/static/chunks/895ba6977f5053015e9e016fed6661f9ab36cd04-60f2c2bc67249d9aaccc.js" as="script"/><link rel="preload" href="/_next/static/chunks/48fdd7256f80fb94ae03bb8376daaf332006598f-57717a6fae3502671973.js" as="script"/><link rel="preload" href="/_next/static/chunks/be885002fb40cc7f7fa16083791a8fd2ec319631-e0089d9d76088513970b.js" as="script"/><link rel="preload" href="/_next/static/chunks/pages/_app-7ff896ec5bdb2f5e64b4.js" as="script"/><link rel="preload" href="/_next/static/chunks/00323929fb7e7d2324d5f42d6037c2e7e0049a95-98d431750c283c30030f.js" as="script"/><link rel="preload" href="/_next/static/chunks/27fbac8685eaf73cf52fea6bbc24ab8b53422732-a6764960847e707cebce.js" as="script"/><link rel="preload" href="/_next/static/chunks/ae11a4047b98c2c4608af644a9d641e8e78da6da-a75fcba4ba793a7a6962.js" as="script"/><link rel="preload" href="/_next/static/chunks/db610b5eeb4d4fb0f1f5691a0a08472f7ff0837f-4a480a54f040d8026faf.js" as="script"/><link rel="preload" href="/_next/static/chunks/6101cb7e308ffa7d701941b6185c8507e6dab9e5-2d4baa6c753edfe9b952.js" as="script"/><link rel="preload" href="/_next/static/chunks/69a3121a9e79c67375be2c86c058c066ef1c1240-27f2058df6443747750e.js" as="script"/><link rel="preload" href="/_next/static/chunks/7e893c104a912c761af0a3a093a3988fc90bae31-1a5604ba598e9c9674b8.js" as="script"/><link rel="preload" href="/_next/static/chunks/166a40466f8df4ccbe6bdd19bddae51aec5eb7ad-fc2c01fb7fef06ba111c.js" as="script"/><link rel="preload" href="/_next/static/chunks/347d642cae0bd24473732eee5cfa6fb6a58e6f94-9b5c69651eff400d2b95.js" as="script"/><link rel="preload" href="/_next/static/chunks/4d8df32be2157e8142c5d02a0431555ac69d6091-6a8b48bcd59107aa3296.js" as="script"/><link rel="preload" href="/_next/static/chunks/c6e9f122557257a42a24f5a2e9e9bed9e2d8b1ac-c71855162e80b790dcef.js" as="script"/><link rel="preload" href="/_next/static/chunks/314d9dd6171cce00a9834745f068750163497462-df4d1129e42ff79be500.js" as="script"/><link rel="preload" href="/_next/static/chunks/e09413e817c513de8393e73173134753fc475924-f4a01da3646febaf8b72.js" as="script"/><link rel="preload" href="/_next/static/chunks/00a288d86759dfc76ed68529556d6882bbd900bd-326f90cd0d859b8f794c.js" as="script"/><link rel="preload" href="/_next/static/chunks/882c1961928b181a903ddace877eeb5ab7592a80-c5b9ae18c12f43ec3453.js" as="script"/><link rel="preload" href="/_next/static/chunks/34a0bf1a95715457bccd477deba4eb1b07e7d57d-930bd1a858df891c4126.js" as="script"/><link rel="preload" href="/_next/static/chunks/pages/posts/%5Bslug%5D-879015683fbe2d2c4f97.js" as="script"/></head><body><div id="__next"><div class="styles_font__2Nqit styles_grey__3J1TQ styles_medium__3fSwd styles_normal__iGf4Q styles_header__3mHfP styles_lineHeight__2RYYy"><div class="styles_constraintWidth__3mc1j styles_content__2ZK2u" style="max-width:1100px"><a class="styles_logo__1wIx6" title="Product Hunt Logo" href="/"><svg width="40" height="40" viewBox="0 0 40 40" xmlns="http://www.w3.org/2000/svg"><g fill="none" fill-rule="evenodd"><path d="M40 20c0 11.046-8.954 20-20 20S0 31.046 0 20 8.954 0 20 0s20 8.954 20 20" fill="#DA552F"></path><path d="M22.667 20H17v-6h5.667a3 3 0 010 6m0-10H13v20h4v-6h5.667a7 7 0 100-14" fill="#FFF"></path></g></svg></a><div class="styles_search__2eqPK"><form class="styles_form__fXh1e" method="GET" action="/search"><label class="styles_font__2Nqit styles_small__2bw6M styles_normal__iGf4Q styles_lineHeight__2RYYy styles_underline__20yPd"><svg width="16" height="16" xmlns="http://www.w3.org/2000/svg" class="styles_searchIcon__1g65n"><path d="M15.707 13.293L13 10.586A6.95 6.95 0 0014 7c0-3.86-3.141-7-7-7S0 3.14 0 7s3.141 7 7 7a6.937 6.937 0 003.586-1l2.707 2.707a.997.997 0 001.414 0l1-1a.999.999 0 000-1.414zM7 12a5 5 0 11.001-10.001A5 5 0 017 12z" fill="#6f6f6f"></path></svg><div><input autoComplete="off" class="styles_input__1J4M7" data-test="search-input" name="q" placeholder="Discover your next favorite thing…" value="" title="Search"/></div><button class="styles_close__2y9g1" type="reset"><svg width="12" height="12" viewBox="0 0 12 12" xmlns="http://www.w3.org/2000/svg"><path d="M6 4.586l4.24-4.24a1 1 0 111.416 1.413L7.413 6l4.24 4.24a1 1 0 11-1.413 1.416L6 7.413l-4.24 4.24A1 1 0 11.344 10.24L4.587 6 .347 1.76A1 1 0 111.757.343L6 4.587z" fill-rule="evenodd"></path></svg></button></label></form></div><nav class="styles_navigation__36MCQ"><ul><li><a href="/founder-club/benefits">Deals</a></li><li><a href="/jobs">Jobs</a></li><li><a href="/makers/discussions">Discussions</a></li><li><a href="/ship" title="More options" data-test="header-ship-link">Ship</a></li><li><a href="/mentors">Mentors</a></li><li><a href="#" title="More options" class="styles_metaMenu__1zykr" data-test="more"><span class="styles_icon__1LaZe" title="More"><svg width="20" height="4" viewBox="0 0 20 4" xmlns="http://www.w3.org/2000/svg"><path d="M2 4A2 2 0 102.001.001 2 2 0 002 4zm8 0a2 2 0 10.001-3.999A2 2 0 0010 4zm8 0a2 2 0 10.001-3.999A2 2 0 0018 4z" fill="#BBB" fill-rule="evenodd"></path></svg></span></a></li></ul></nav><nav class="styles_actions__1fPM3"><div class="styles_loginButtons__2DZoi"><a class="style_button__1hC0M style_mediumSize__nAE00 style_simpleVariant__KNa2A styles_button__2cdRX" data-test="login-button" href="/login"><span class="styles_font__2Nqit styles_xSmall__1eYHj styles_semiBold__2IC3i style_buttonContainer__1tRlx styles_lineHeight__2RYYy styles_underline__20yPd styles_uppercase__2YIgd">Log In</span></a><a class="style_button__1hC0M style_mediumSize__nAE00 style_orangeSolidColor__3B-ZC style_solidVariant__1KeFK styles_button__2cdRX styles_signUpButton__2vVKD" href="/login"><span class="styles_font__2Nqit styles_xSmall__1eYHj styles_semiBold__2IC3i style_buttonContainer__1tRlx styles_lineHeight__2RYYy styles_underline__20yPd styles_uppercase__2YIgd">Sign up</span></a></div></nav></div></div><main class=""><div class="styles_header__2lPSD"><div class="styles_constraintWidth__3mc1j" style="max-width:1100px"><div class="styles_breadcrumbs__1lXVN"><ol class="styles_font__2Nqit styles_grey__3J1TQ styles_xSmall__1eYHj styles_normal__iGf4Q styles_lineHeight__2RYYy styles_underline__20yPd styles_uppercase__2YIgd"><li><a href="/">Home</a></li><li><span> → </span><a href="/posts/robo-esso">Robo Esso</a></li></ol></div></div><div class="styles_constraintWidth__3mc1j styles_headerContent__3hmXo" style="max-width:1100px"><div class="styles_thumbnail__d2DAK" data-test="post-thumbnail"><span class="lazyload-wrapper"><div style="height:100px" class="lazyload-placeholder"></div></span></div><div class="styles_headerInfo__3h0jF"><h1 class="styles_font__2Nqit styles_xLarge__24CcJ styles_headerPostName__a8Dcz styles_lineHeight__2RYYy styles_underline__20yPd"><a target="_blank" href="/r/a4eb5ec4848507">Robo Esso</a><a href="#" title="More options" class="style_toggle__TYiT2" data-test="post-actions"><span><svg width="12" height="7" viewBox="0 0 12 7" xmlns="http://www.w3.org/2000/svg"><path d="M5.998 6.244a.99.99 0 01-.703-.292L1.048 1.705A1.003 1.003 0 011.05.293.996.996 0 012.462.29L6 3.83 9.538.29a1.003 1.003 0 011.412.003.997.997 0 01.002 1.412L6.705 5.952a.992.992 0 01-.702.29z" fill="#CCC8C7"></path></svg></span></a></h1><h2 class="styles_font__2Nqit styles_grey__3J1TQ styles_medium__3fSwd styles_normal__iGf4Q styles_headerPostTagline__1XCBw styles_lineHeight__2RYYy styles_underline__20yPd">Automated coffee shop using off-the-shelf hardware</h2><div class="styles_headerTopicList__1Yf7A"><div class="styles_font__2Nqit styles_grey__3J1TQ styles_xSmall__1eYHj styles_normal__iGf4Q styles_item__13V32 styles_button__3TLZg styles_lineHeight__2RYYy styles_underline__20yPd styles_uppercase__2YIgd"><a title="Robots" href="/topics/robots">Robots</a><span class="styles_toggle__2e8gC" data-test="follow-button"></span></div><div class="styles_font__2Nqit styles_grey__3J1TQ styles_xSmall__1eYHj styles_normal__iGf4Q styles_item__13V32 styles_button__3TLZg styles_lineHeight__2RYYy styles_underline__20yPd styles_uppercase__2YIgd"><a title="Coffee" href="/topics/coffee">Coffee</a><span class="styles_toggle__2e8gC" data-test="follow-button"></span></div><div class="styles_font__2Nqit styles_grey__3J1TQ styles_xSmall__1eYHj styles_normal__iGf4Q styles_item__13V32 styles_button__3TLZg styles_lineHeight__2RYYy styles_underline__20yPd styles_uppercase__2YIgd"><a title="Tech" href="/topics/tech">Tech</a><span class="styles_toggle__2e8gC" data-test="follow-button"></span></div></div></div></div></div><div class="styles_container__1aGWY"><div class="styles_main__48OVQ"><section class="styles_container__3xLls styles_descriptionWrap__3GruT spacings_large__3NY-z"><div class="styles_content__2SyXA styles_white__13AB5 styles_padding__2Z8vM"><section><div class="styles_canvas__3UCB9" style="height:380px"><ol><li style="height:380px"><div class="styles_video__2hHMo" style="height:380px;width:672.566371681416px"><div class=""><div></div></div></div></li><li style="height:380px"><a href="https://ph-files.imgix.net/7c064eb7-f17e-44e5-8e72-2f96dca774c9.jpeg?auto=format&amp;auto=compress&amp;codec=mozjpeg&amp;cs=strip" target="_blank"><span class="lazyload-wrapper"><div style="height:380px" class="lazyload-placeholder"></div></span></a></li><li style="height:380px"><a href="https://ph-files.imgix.net/46e2b280-02f2-4c28-a23a-1a7bb744929f.png?auto=format&amp;auto=compress&amp;codec=mozjpeg&amp;cs=strip" target="_blank"><span class="lazyload-wrapper"><div style="height:380px" class="lazyload-placeholder"></div></span></a></li><li style="height:380px"><a href="https://ph-files.imgix.net/c7775718-608f-40ec-9d74-3d355ae848d7.jpeg?auto=format&amp;auto=compress&amp;codec=mozjpeg&amp;cs=strip" target="_blank"><span class="lazyload-wrapper"><div style="height:380px" class="lazyload-placeholder"></div></span></a></li></ol></div><div class="styles_thumbnails__3pdKI"><div class="styles_thumbnail__31Vqt"><span class="lazyload-wrapper"><div style="height:40px" class="lazyload-placeholder"></div></span></div><div class="styles_thumbnail__31Vqt"><span class="lazyload-wrapper"><div style="height:40px" class="lazyload-placeholder"></div></span></div><div class="styles_thumbnail__31Vqt"><span class="lazyload-wrapper"><div style="height:40px" class="lazyload-placeholder"></div></span></div><div class="styles_thumbnail__31Vqt"><span class="lazyload-wrapper"><div style="height:40px" class="lazyload-placeholder"></div></span></div></div></section><div class="styles_font__2Nqit styles_black__1okrd styles_small__2bw6M styles_normal__iGf4Q styles_withTopBorder__4q54F styles_container__2pk4p styles_lineHeight__2RYYy styles_underline__20yPd"><div class="styles_description__2-RUk"><div class="styles_font__2Nqit styles_small__2bw6M styles_normal__iGf4Q styles_format__219oD styles_lineHeight__2RYYy styles_underline__20yPd"><div>Robot coffee shop using off-the-shelf equipment to customize their menu faster and offer a larger variety of drinks at a lower price than other robot coffee shops.</div></div></div></div><div style="max-width:100%" class="styles_flex__363IJ styles_responsive__96EZc styles_flex-align-center__1-Br9 styles_flex-direction-row__3hU_w styles_flex-justify-center__3kSv0 styles_social__2-Nd5"><div style="max-width:100%" class="styles_flex__363IJ styles_flex-align-center__1-Br9 styles_flex-direction-row__3hU_w styles_flex-justify-flex-start__Gev7x styles_row-item-margin-small__ExVrU styles_socialButtons__1t5Cc"><button class="style_button__1hC0M style_mediumSize__nAE00 style_simpleVariant__KNa2A styles_twitterButton__YlBiz styles_bordered__1rLoB" data-test="tweet-button"><span class="styles_font__2Nqit styles_xSmall__1eYHj styles_semiBold__2IC3i style_buttonContainer__1tRlx styles_lineHeight__2RYYy styles_underline__20yPd styles_uppercase__2YIgd"><svg width="16" height="13" viewBox="0 0 16 13" xmlns="http://www.w3.org/2000/svg" class="styles_buttonIcon__pW8TS"><path d="M15.999 1.537a6.57 6.57 0 01-1.885.517A3.296 3.296 0 0015.557.238a6.576 6.576 0 01-2.084.796A3.282 3.282 0 007.88 4.027 9.32 9.32 0 011.112.599 3.28 3.28 0 002.13 4.98a3.27 3.27 0 01-1.487-.41v.042a3.284 3.284 0 002.633 3.217 3.29 3.29 0 01-1.483.056 3.286 3.286 0 003.067 2.28A6.587 6.587 0 010 11.523a9.29 9.29 0 005.032 1.475c6.038 0 9.34-5.001 9.34-9.338 0-.143-.004-.284-.01-.425a6.673 6.673 0 001.637-1.698H16z"></path></svg><span class="styles_buttonLabel__3iq0D">Tweet</span></span></button><button class="style_button__1hC0M style_mediumSize__nAE00 style_simpleVariant__KNa2A styles_facebookButton__1hgpH styles_bordered__2oeC2"><span class="styles_font__2Nqit styles_xSmall__1eYHj styles_semiBold__2IC3i style_buttonContainer__1tRlx styles_lineHeight__2RYYy styles_underline__20yPd styles_uppercase__2YIgd"><svg width="8" height="13" viewBox="0 0 8 14" xmlns="http://www.w3.org/2000/svg" class="styles_buttonIcon__1uPU-"><path d="M7.2 2.323H5.923c-1.046 0-1.278.464-1.278 1.16V5.11h2.44l-.35 2.438h-2.09v6.387H2.09V7.548H0V5.11h2.09V3.252C2.09 1.162 3.368 0 5.342 0c.93 0 1.742.116 1.858.116v2.207z" fill="#FFF" fill-rule="evenodd"></path></svg><span class="styles_buttonLabel__3EeEz">Share</span></span></button><a class="style_button__1hC0M style_mediumSize__nAE00 style_simpleVariant__KNa2A styles_button__3prl2" href="/posts/robo-esso/embed"><span class="styles_font__2Nqit styles_xSmall__1eYHj styles_semiBold__2IC3i style_buttonContainer__1tRlx styles_lineHeight__2RYYy styles_underline__20yPd styles_uppercase__2YIgd"><span><svg width="19" height="13" viewBox="0 0 19 13" xmlns="http://www.w3.org/2000/svg"><path d="M13.8 3.904V2l5 3.691v1.455l-5 3.702V8.934l3.493-2.325.496-.166v-.058l-.496-.196L13.8 3.904zM7.917 12.44H6.4l5.492-12H13.4l-5.483 12zM2.475 6.238l-.531.176v.059l.531.185 3.494 2.227v1.963l-5.1-3.702V5.691L5.969 2v1.963L2.475 6.238z" fill-rule="evenodd"></path></svg></span>Embed</span></a><button class="style_button__1hC0M style_mediumSize__nAE00 style_subtleVariant__33mz7 style_simpleVariant__KNa2A styles_button__14vnx" data-test="collect-button" title="Add to collection"><span class="styles_font__2Nqit styles_xSmall__1eYHj styles_semiBold__2IC3i style_buttonContainer__1tRlx styles_lineHeight__2RYYy styles_underline__20yPd styles_uppercase__2YIgd"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16 15"><path d="M11.182.25c1.135 0 2.116.756 2.199 1.79l.005.142v4.916h-1.5V2.182c0-.18-.23-.386-.583-.425l-.121-.007H2.455c-.378 0-.647.188-.697.371l-.008.06v10.637c0 .18.23.386.583.425l.122.007h5.84v1.5h-5.84c-1.136 0-2.116-.756-2.2-1.79l-.005-.142V2.182c0-1.057.93-1.86 2.05-1.927L2.456.25h8.727zm2.204 8.636v2.182h2.182v1.5h-2.182v2.182h-1.5v-2.182H9.705v-1.5h2.181V8.886h1.5z"></path></svg> <!-- -->Collect</span></button></div><span class="styles_font__2Nqit styles_grey__3J1TQ styles_xSmall__1eYHj styles_normal__iGf4Q styles_timestamp__3iI3K styles_lineHeight__2RYYy styles_underline__20yPd styles_uppercase__2YIgd">Featured <time dateTime="2021-02-04T08:51:19-08:00" title="0004, February 4th 2021, 8:51:19 AM">10m ago</time></span></div></div></section><div class="styles_container__3xLls spacings_large__3NY-z"><div class="styles_header__1DfPW"><span class="styles_font__2Nqit styles_grey__3J1TQ styles_xSmall__1eYHj styles_semiBold__2IC3i styles_headerTitle__1eOK3 styles_lineHeight__2RYYy styles_underline__20yPd styles_uppercase__2YIgd"><div style="max-width:100%" class="styles_flex__363IJ styles_flex-align-center__1-Br9 styles_flex-direction-row__3hU_w styles_flex-justify-space-between__SKwKl" id="discussion-body"><span class="styles_font__2Nqit styles_xSmall__1eYHj styles_semiBold__2IC3i styles_lineHeight__2RYYy styles_underline__20yPd">discussion</span><button class="style_button__1hC0M style_mediumSize__nAE00 style_linkVariant__D6oNl styles_button__3qA3F"><span class="styles_font__2Nqit styles_xSmall__1eYHj styles_semiBold__2IC3i style_buttonContainer__1tRlx styles_lineHeight__2RYYy styles_underline__20yPd styles_uppercase__2YIgd"><span class="styles_font__2Nqit styles_blue__3OsYT styles_lineHeight__2RYYy styles_underline__20yPd">follow<!-- --> discussion</span><div><div class="styles_tooltip__11DxU"><svg width="12" height="12" xmlns="http://www.w3.org/2000/svg"><path d="M6 0C2.7 0 0 2.7 0 6s2.7 6 6 6 6-2.7 6-6-2.7-6-6-6zm0 9.75c-.45 0-.75-.3-.75-.75s.3-.75.75-.75.75.3.75.75-.3.75-.75.75zM7.125 6.3c-.375.225-.375.3-.375.45v.75h-1.5v-.75c0-.975.6-1.425 1.05-1.725.375-.225.45-.3.45-.525 0-.45-.3-.75-.75-.75-.3 0-.525.15-.675.375L4.95 4.8l-1.275-.75.375-.675A2.238 2.238 0 016 2.25c1.275 0 2.25.975 2.25 2.25 0 1.05-.675 1.5-1.125 1.8z" fill="#999"></path></svg></div></div></span></button></div></span></div><div class="styles_content__2SyXA styles_white__13AB5 styles_padding__2Z8vM"><div class="styles_container__1AlIM"><div class="styles_reviewContainer__3797i"><div class="styles_actions__2vabN"><span class="styles_font__2Nqit styles_small__2bw6M styles_semiBold__2IC3i styles_lineHeight__2RYYy styles_underline__20yPd">Would you recommend this product?</span><div class="styles_buttonFaces__3i_rv"><button class="style_button__1hC0M style_smallSize__VxjQq style_simpleVariant__KNa2A styles_positive__WSqbF" data-test="positive-sentiment-button"><span class="styles_font__2Nqit styles_xSmall__1eYHj styles_semiBold__2IC3i style_buttonContainer__1tRlx styles_lineHeight__2RYYy styles_underline__20yPd styles_uppercase__2YIgd"><svg width="22" height="22" viewBox="0 0 22 22" xmlns="http://www.w3.org/2000/svg"><g fill="#66BE00"><path d="M11 20.975c-5.5 0-9.975-4.475-9.975-9.975S5.5 1.025 11 1.025 20.975 5.5 20.975 11 16.5 20.975 11 20.975zM10.999 1.52c-5.227 0-9.48 4.252-9.48 9.48 0 5.228 4.253 9.48 9.48 9.48s9.48-4.252 9.48-9.48c0-5.228-4.253-9.48-9.48-9.48z" stroke="#7CBC00"></path><path d="M11.054 15.43a6.555 6.555 0 01-4.42-1.727.477.477 0 01.648-.698 5.589 5.589 0 003.772 1.47 5.595 5.595 0 003.674-1.386.482.482 0 01.673.04.482.482 0 01-.04.673 6.467 6.467 0 01-4.307 1.629zm5.585-5.682c.099.064.232-.01.232-.13v-.004a1.288 1.288 0 00-2.574 0v.005c0 .119.134.188.233.129a1.995 1.995 0 011.05-.298 1.92 1.92 0 011.059.298zm-9.174 0c.1.064.233-.01.233-.13v-.004a1.288 1.288 0 00-2.574 0v.005c0 .119.133.188.232.129a1.995 1.995 0 011.05-.298 1.93 1.93 0 011.06.298z"></path></g></svg>Yes</span></button><button class="style_button__1hC0M style_smallSize__VxjQq style_simpleVariant__KNa2A styles_negative__2Nzq5" data-test="negative-sentiment-button"><span class="styles_font__2Nqit styles_xSmall__1eYHj styles_semiBold__2IC3i style_buttonContainer__1tRlx styles_lineHeight__2RYYy styles_underline__20yPd styles_uppercase__2YIgd"><svg width="22" height="22" viewBox="0 0 22 22" xmlns="http://www.w3.org/2000/svg"><g fill="#F95353"><path d="M11 20.975c-5.5 0-9.975-4.475-9.975-9.975S5.5 1.025 11 1.025 20.975 5.5 20.975 11 16.5 20.975 11 20.975zM11 1.52c-5.228 0-9.48 4.252-9.48 9.48 0 5.228 4.252 9.48 9.48 9.48 5.228 0 9.48-4.252 9.48-9.48 0-5.228-4.252-9.48-9.48-9.48z" stroke="#F95353"></path><path d="M4.317 9.97a.339.339 0 01-.164-.044.32.32 0 01-.108-.436c.534-.9 1.505-1.5 2.435-1.48a.319.319 0 01.312.322.318.318 0 01-.317.312h-.03c-.697 0-1.44.465-1.85 1.168a.335.335 0 01-.278.158zm13.366 0a.315.315 0 01-.272-.153c-.416-.703-1.159-1.168-1.857-1.168h-.03a.315.315 0 01-.316-.312.316.316 0 01.312-.322c.916-.02 1.9.58 2.435 1.48.09.149.04.347-.113.436a.341.341 0 01-.159.04zm-3.099 1.565a.093.093 0 00-.134.099c.12.584.694 1.03 1.387 1.03.698 0 1.272-.446 1.39-1.03.016-.075-.064-.139-.133-.1a2.55 2.55 0 01-1.257.322 2.585 2.585 0 01-1.253-.321zm-9.678 0c-.07-.035-.149.024-.134.099.114.584.693 1.03 1.391 1.03.698 0 1.273-.446 1.387-1.03.014-.075-.065-.139-.134-.1a2.55 2.55 0 01-1.258.322 2.6 2.6 0 01-1.252-.321zm9.5 5.064c.297.05.5-.297.302-.525-.861-1-2.203-1.638-3.708-1.638-1.505 0-2.847.643-3.708 1.638-.198.228.005.575.302.525A21.819 21.819 0 0111 16.342c1.228.005 2.381.094 3.406.257z"></path></g></svg>No</span></button></div></div></div></div><div><div data-test="thread-1261310" class="styles_threadContainer__mp03X"><div class="styles_container__1BIlC" id="comment-1261310" data-test="comment-1261310"><div class="styles_userDetails__1gOQ9"><div class="styles_blockSpotlight__2xtKO styles_userSpotlight__dQuvK"><div class="styles_image__3B_im"><div><div><a data-test="user-image-link-2363" class="styles_link__2yHMA" href="/@freemanlafleur"><div class="styles_container__mO53e"><span class="lazyload-wrapper"><div style="height:30px" class="lazyload-placeholder"></div></span></div></a></div></div></div><div class="styles_content__3K0ea"><span class="styles_font__2Nqit styles_black__1okrd styles_small__2bw6M styles_semiBold__2IC3i styles_headline__1QxGb styles_lineHeight__2RYYy styles_underline__20yPd"><a href="/@freemanlafleur">Freeman LaFleur</a><span class="styles_userNotice__xRlys"><span><div class="styles_badge__BNjUD styles_hunter__1_rhW styles_small__3ZqCi styles_badge__33szw">Hunter</div></span></span></span><span class="styles_font__2Nqit styles_grey__3J1TQ styles_small__2bw6M styles_normal__iGf4Q styles_text__17VS6 styles_lineHeight__2RYYy styles_underline__20yPd">Digital Strategist</span></div></div></div><div class="styles_commentContainer__2HSK4"><div class="styles_formContainer__3VGsv"><div class="styles_font__2Nqit styles_small__2bw6M styles_normal__iGf4Q spacings_small__AQuIC styles_overflowHidden__21abY styles_format__219oD styles_lineHeight__2RYYy styles_underline__20yPd">This is my friend's project. I found it interesting that he uses off-the-shelf robotics hardware to avoid hardware development costs. I believe the ordering app was developed in-house but maybe he can chime in with more details. He is currently looking for investors through Mainvest.</div></div><div class="styles_font__2Nqit styles_grey__3J1TQ styles_xSmall__1eYHj styles_semiBold__2IC3i styles_commentOptions__3G1fl styles_lineHeight__2RYYy styles_underline__20yPd styles_uppercase__2YIgd"><div class="styles_voteButtonWrapper__dCNxh"><div><div><button class="style_button__1hC0M style_smallSize__VxjQq style_simpleVariant__KNa2A styles_voteButton__3dplQ styles_commentActionButton__2zxJj" data-test="comment-vote-button"><span class="styles_font__2Nqit styles_xSmall__1eYHj styles_semiBold__2IC3i style_buttonContainer__1tRlx styles_lineHeight__2RYYy styles_underline__20yPd styles_uppercase__2YIgd"><span class="styles_upvoteIcon__2g6hH"></span>Upvote<!-- --> (1)</span></button></div></div></div><a href="#" title="More options" class="styles_optionItem__28gRV styles_commentActionButton__2zxJj">Share</a><a class="styles_font__2Nqit styles_light__1wDke styles_optionItem__28gRV styles_lineHeight__2RYYy styles_underline__20yPd" href="/posts/robo-esso#comment-1261310"><time dateTime="2021-02-04T08:51:21-08:00" title="0004, February 4th 2021, 8:51:21 AM">10m ago</time></a><a href="#" title="More options" class="styles_dotMenuToggle__2FRLT" data-test="comment-menu-button"><svg width="15" height="3" viewBox="0 0 15 3" xmlns="http://www.w3.org/2000/svg"><g fill="#9B9B9B" fill-rule="evenodd"><circle cx="1.5" cy="1.5" r="1.5"></circle><circle cx="7.5" cy="1.5" r="1.5"></circle><circle cx="13.5" cy="1.5" r="1.5"></circle></g></svg></a></div></div></div></div><div data-test="thread-1261321" class="styles_threadContainer__mp03X"><div class="styles_container__1BIlC" id="comment-1261321" data-test="comment-1261321"><div class="styles_userDetails__1gOQ9"><div class="styles_blockSpotlight__2xtKO styles_userSpotlight__dQuvK"><div class="styles_image__3B_im"><div><div><a data-test="user-image-link-3174036" class="styles_link__2yHMA" href="/@roboesso"><div class="styles_container__mO53e"><span class="lazyload-wrapper"><div style="height:30px" class="lazyload-placeholder"></div></span></div></a></div></div></div><div class="styles_content__3K0ea"><span class="styles_font__2Nqit styles_black__1okrd styles_small__2bw6M styles_semiBold__2IC3i styles_headline__1QxGb styles_lineHeight__2RYYy styles_underline__20yPd"><a href="/@roboesso">Matthew Jones</a><span class="styles_userNotice__xRlys"><span><div class="styles_badge__BNjUD styles_maker__2vVSC styles_small__3ZqCi styles_badge__33szw">Maker</div></span><div class="styles_badge__3Uy1C styles_karmaBadge__3IDoo"><div><div>🎈</div></div></div></span></span><span class="styles_font__2Nqit styles_grey__3J1TQ styles_small__2bw6M styles_normal__iGf4Q styles_text__17VS6 styles_lineHeight__2RYYy styles_underline__20yPd">Founder of Robo Esso</span></div></div></div><div class="styles_commentContainer__2HSK4"><div class="styles_formContainer__3VGsv"><div class="styles_font__2Nqit styles_small__2bw6M styles_normal__iGf4Q spacings_small__AQuIC styles_overflowHidden__21abY styles_format__219oD styles_lineHeight__2RYYy styles_underline__20yPd">Thanks Freeman! Yes! We're raising to open a new location, let me know if you have questions! <a href="https://mainvest.com/b/robo-esso-golden" target="_blank" rel="nofollow noopener noreferrer">https://mainvest.com/b/robo-esso...</a></div></div><div class="styles_font__2Nqit styles_grey__3J1TQ styles_xSmall__1eYHj styles_semiBold__2IC3i styles_commentOptions__3G1fl styles_lineHeight__2RYYy styles_underline__20yPd styles_uppercase__2YIgd"><div class="styles_voteButtonWrapper__dCNxh"><button class="style_button__1hC0M style_smallSize__VxjQq style_simpleVariant__KNa2A styles_voteButton__3dplQ styles_commentActionButton__2zxJj" data-test="comment-vote-button"><span class="styles_font__2Nqit styles_xSmall__1eYHj styles_semiBold__2IC3i style_buttonContainer__1tRlx styles_lineHeight__2RYYy styles_underline__20yPd styles_uppercase__2YIgd"><span class="styles_upvoteIcon__2g6hH"></span>Upvote</span></button></div><a href="#" title="More options" class="styles_optionItem__28gRV styles_commentActionButton__2zxJj">Share</a><a class="styles_font__2Nqit styles_light__1wDke styles_optionItem__28gRV styles_lineHeight__2RYYy styles_underline__20yPd" href="/posts/robo-esso#comment-1261321"><time dateTime="2021-02-04T08:55:26-08:00" title="0004, February 4th 2021, 8:55:26 AM">6m ago</time></a><a href="#" title="More options" class="styles_dotMenuToggle__2FRLT" data-test="comment-menu-button"><svg width="15" height="3" viewBox="0 0 15 3" xmlns="http://www.w3.org/2000/svg"><g fill="#9B9B9B" fill-rule="evenodd"><circle cx="1.5" cy="1.5" r="1.5"></circle><circle cx="7.5" cy="1.5" r="1.5"></circle><circle cx="13.5" cy="1.5" r="1.5"></circle></g></svg></a></div></div></div></div></div><form class="styles_form__3nehg styles_commentFormBottom__1SDpb" data-test="comment-form"><div class="styles_container__mO53e"><img src="https://ph-static.imgix.net/guest-user-avatar.png?auto=format&amp;auto=compress&amp;codec=mozjpeg&amp;cs=strip&amp;w=30&amp;h=30&amp;fit=crop" srcSet="https://ph-static.imgix.net/guest-user-avatar.png?auto=format&amp;auto=compress&amp;codec=mozjpeg&amp;cs=strip&amp;w=30&amp;h=30&amp;fit=crop&amp;dpr=2 2x" style="width:30px;height:30px" alt="" class="styles_image__2cVru"/></div><div class="styles_container__1LH_W"><div class="styles_container__2JahO"><label class="styleguide_field__w1Wvb styles_field__1XI6t"><div class="rta  "><textarea name="body" rows="1" placeholder="What do you think of this product?" data-test="new-comment-body" title="Write a comment" class="rta__textarea "></textarea></div></label></div></div><button class="style_button__1hC0M style_mediumSize__nAE00 style_orangeSolidColor__3B-ZC style_solidVariant__1KeFK" type="submit"><span class="styles_font__2Nqit styles_xSmall__1eYHj styles_semiBold__2IC3i style_buttonContainer__1tRlx styles_lineHeight__2RYYy styles_underline__20yPd styles_uppercase__2YIgd">Send</span></button></form></div></div></div><aside class="styles_aside__1Wl8x"><div class="styles_container__3xLls styles_container__EElPy spacings_large__3NY-z"><div class="styles_content__2SyXA styles_white__13AB5 styles_padding__2Z8vM"><div class="styles_font__2Nqit styles_grey__3J1TQ styles_xSmall__1eYHj styles_normal__iGf4Q styles_hunter__1oa2L styles_lineHeight__2RYYy styles_underline__20yPd styles_uppercase__2YIgd">Hunter</div><div class="styles_makersContainer__1N77x"><a class="styles_card__lc6A-" href="/@freemanlafleur"><div><div><div class="styles_container__mO53e"><span class="lazyload-wrapper"><div style="height:30px" class="lazyload-placeholder"></div></span></div></div></div><div class="styles_content__2OcVn"><div class="styles_font__2Nqit styles_small__2bw6M styles_semiBold__2IC3i styles_title__1J4mU styles_lineHeight__2RYYy styles_underline__20yPd">Freeman LaFleur</div><span class="styles_font__2Nqit styles_grey__3J1TQ styles_small__2bw6M styles_normal__iGf4Q styles_lineHeight__2RYYy styles_underline__20yPd text_ellipsis__30DQG">Digital Strategist</span></div></a></div><div class="styles_font__2Nqit styles_grey__3J1TQ styles_xSmall__1eYHj styles_normal__iGf4Q styles_makers__11RgN styles_lineHeight__2RYYy styles_underline__20yPd styles_uppercase__2YIgd">1 Maker</div><div class="styles_makersContainer__1N77x"><a class="styles_card__lc6A-" href="/@roboesso"><div><div><div class="styles_container__mO53e"><span class="lazyload-wrapper"><div style="height:30px" class="lazyload-placeholder"></div></span></div></div></div><div class="styles_content__2OcVn"><div class="styles_font__2Nqit styles_small__2bw6M styles_semiBold__2IC3i styles_title__1J4mU styles_lineHeight__2RYYy styles_underline__20yPd">Matthew Jones</div><span class="styles_font__2Nqit styles_grey__3J1TQ styles_small__2bw6M styles_normal__iGf4Q styles_lineHeight__2RYYy styles_underline__20yPd text_ellipsis__30DQG">Founder of Robo Esso</span></div></a><div class="styles_gradient__qedcY"></div></div></div></div><section class="styles_container__3jlpg"><div class="styles_title__1eR3V"><span class="styles_font__2Nqit styles_grey__3J1TQ styles_xSmall__1eYHj styles_semiBold__2IC3i styles_lineHeight__2RYYy styles_underline__20yPd styles_uppercase__2YIgd">Related Products</span></div><div class="styles_items__32BIn"></div></section></aside></div></main></div><script id="__NEXT_DATA__" type="application/json">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</script><script nomodule="" src="/_next/static/chunks/polyfills-8fb675717f8c9b4b0aa0.js"></script><script src="/_next/static/chunks/main-fdb656bebd38829c0c01.js" async=""></script><script src="/_next/static/chunks/webpack-a198f19b9e116df221ff.js" async=""></script><script src="/_next/static/chunks/framework-33e18a7bef76c30e15eb.js" async=""></script><script src="/_next/static/chunks/commons-18dad7f673c57e404bcb.js" async=""></script><script src="/_next/static/chunks/69a2a245045fb191ff81ee6aa3481b2a36f5eac3-6d9be4de0bc30217d1d9.js" async=""></script><script src="/_next/static/chunks/995607c2d9eda3fbda8bfd26d8ce135465b8466c-e7dc6fc92bbf5978aa24.js" async=""></script><script src="/_next/static/chunks/87553e297503562a4ae6e9014c11c4cb95affe46-ed9eaeb8839d8469cc98.js" async=""></script><script src="/_next/static/chunks/a38a7eedb7cc15033afc318ff4b5d143d28d1483-956a6d94cdb1d898d8bb.js" async=""></script><script src="/_next/static/chunks/86d29cfda7579c9a258278c079eaf20143224b95-d1000dbc8ed6b6c80d07.js" async=""></script><script src="/_next/static/chunks/fb9b3eab6cb961ac801d4488d9d08b5499fd5367-bc51a7e142a6fe8fa205.js" async=""></script><script src="/_next/static/chunks/b2732580c67f88cf649a6bca17272673f857ee6c-93bcf5d7c5047ffbb68f.js" async=""></script><script src="/_next/static/chunks/895ba6977f5053015e9e016fed6661f9ab36cd04-60f2c2bc67249d9aaccc.js" async=""></script><script src="/_next/static/chunks/48fdd7256f80fb94ae03bb8376daaf332006598f-57717a6fae3502671973.js" async=""></script><script src="/_next/static/chunks/be885002fb40cc7f7fa16083791a8fd2ec319631-e0089d9d76088513970b.js" async=""></script><script src="/_next/static/chunks/pages/_app-7ff896ec5bdb2f5e64b4.js" async=""></script><script src="/_next/static/chunks/00323929fb7e7d2324d5f42d6037c2e7e0049a95-98d431750c283c30030f.js" async=""></script><script src="/_next/static/chunks/27fbac8685eaf73cf52fea6bbc24ab8b53422732-a6764960847e707cebce.js" async=""></script><script src="/_next/static/chunks/ae11a4047b98c2c4608af644a9d641e8e78da6da-a75fcba4ba793a7a6962.js" async=""></script><script src="/_next/static/chunks/db610b5eeb4d4fb0f1f5691a0a08472f7ff0837f-4a480a54f040d8026faf.js" async=""></script><script src="/_next/static/chunks/6101cb7e308ffa7d701941b6185c8507e6dab9e5-2d4baa6c753edfe9b952.js" async=""></script><script src="/_next/static/chunks/69a3121a9e79c67375be2c86c058c066ef1c1240-27f2058df6443747750e.js" async=""></script><script src="/_next/static/chunks/7e893c104a912c761af0a3a093a3988fc90bae31-1a5604ba598e9c9674b8.js" async=""></script><script src="/_next/static/chunks/166a40466f8df4ccbe6bdd19bddae51aec5eb7ad-fc2c01fb7fef06ba111c.js" async=""></script><script src="/_next/static/chunks/347d642cae0bd24473732eee5cfa6fb6a58e6f94-9b5c69651eff400d2b95.js" async=""></script><script src="/_next/static/chunks/4d8df32be2157e8142c5d02a0431555ac69d6091-6a8b48bcd59107aa3296.js" async=""></script><script src="/_next/static/chunks/c6e9f122557257a42a24f5a2e9e9bed9e2d8b1ac-c71855162e80b790dcef.js" async=""></script><script src="/_next/static/chunks/314d9dd6171cce00a9834745f068750163497462-df4d1129e42ff79be500.js" async=""></script><script src="/_next/static/chunks/e09413e817c513de8393e73173134753fc475924-f4a01da3646febaf8b72.js" async=""></script><script src="/_next/static/chunks/00a288d86759dfc76ed68529556d6882bbd900bd-326f90cd0d859b8f794c.js" async=""></script><script src="/_next/static/chunks/882c1961928b181a903ddace877eeb5ab7592a80-c5b9ae18c12f43ec3453.js" async=""></script><script src="/_next/static/chunks/34a0bf1a95715457bccd477deba4eb1b07e7d57d-930bd1a858df891c4126.js" async=""></script><script src="/_next/static/chunks/pages/posts/%5Bslug%5D-879015683fbe2d2c4f97.js" async=""></script><script src="/_next/static/AKEEi4_Limlj0doEii8bx/_buildManifest.js" async=""></script><script src="/_next/static/AKEEi4_Limlj0doEii8bx/_ssgManifest.js" async=""></script><div id="root-portal"></div></body><script>!function(){var analytics=window.analytics=window.analytics||[];if(!analytics.initialize)if(analytics.invoked)window.console&&console.error&&console.error("Segment snippet included twice.");else{analytics.invoked=!0;analytics.methods=["trackSubmit","trackClick","trackLink","trackForm","pageview","identify","reset","group","track","ready","alias","page","once","off","on"];analytics.factory=function(t){return function(){var e=Array.prototype.slice.call(arguments);e.unshift(t);analytics.push(e);return analytics}};for(var t=0;t<analytics.methods.length;t++){var e=analytics.methods[t];analytics[e]=analytics.factory(e)}analytics.load=function(t){var e=document.createElement("script");e.type="text/javascript";e.async=!0;e.src=("https:"===document.location.protocol?"https://":"http://")+"cdn.segment.com/analytics.js/v1/"+t+"/analytics.min.js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(e,n)};analytics.SNIPPET_VERSION="3.1.0";
      analytics.load('dtyjquswuq');
      analytics.page();
      }}();</script><script>
  (function() {
    if (window.innerWidth <= 576) {
      return;
    }
    window.intercomSettings = {
      app_id: "fe4ce68d4a8352909f553b276994db414d33a55c"
    };
    (function(){var w=window;var ic=w.Intercom;if(typeof ic==="function"){ic('reattach_activator');ic('update',w.intercomSettings);}else{var d=document;var i=function(){i.c(arguments);};i.q=[];i.c=function(args){i.q.push(args);};w.Intercom=i;var l=function(){var s=d.createElement('script');s.type='text/javascript';s.async=true;s.src='https://widget.intercom.io/widget/fe4ce68d4a8352909f553b276994db414d33a55c';var x=d.getElementsByTagName('script')[0];x.parentNode.insertBefore(s,x);};if(w.attachEvent){w.attachEvent('onload',l);}else{w.addEventListener('load',l,false);}}})();
  })()
</script><script>
  !function(e,t,r,n){if(!e[n]){for(var a=e[n]=[],i=["survey","reset","config","init","set","get","event","identify","track","page","screen","group","alias"],s=0;s<i.length;s++){var c=i[s];a[c]=a[c]||function(e){return function(){var t=Array.prototype.slice.call(arguments);a.push([e,t])}}(c)}a.SNIPPET_VERSION="1.0.1";var o=t.createElement("script");o.type="text/javascript",o.async=!0,o.src="https://d2yyd1h5u9mauk.cloudfront.net/integrations/web/v1/library/"+r+"/"+n+".js";var u=t.getElementsByTagName("script")[0];u.parentNode.insertBefore(o,u)}}(window,document,"JVfbSZuLXA9WNSme","delighted");
  delighted.logLevel = "silent";
</script></html>